注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

山林客

简单不一定幸福,但幸福其实可以很简单。

 
 
 

日志

 
 
关于我

2004年毕业于中山大学,毕业后专注于网站开发和网络工程技术。先后取得SCWCD、CCNP认证,对Asp/Java有丰富的开发经验,对网络工程也有较深的研究。真诚欢迎大家多多指教、多多指点、多多指正,共同分享IT道路和人生道路上的喜怒哀乐。

BGP配置示例  

2008-11-13 23:21:01|  分类: Cisco |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

本例演示了BGP的基本配置。

看拓扑:

BGP配置示例 - 瑞志.net - Bills Tec. Space

R2和R3之间除了运行BGP还运行EIGRP。

1. 基本配置

R1#show run
!        
interface Serial1/2
 ip address 172.16.1.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
!        
router bgp 65100   ——①指定BGP AS号
 no synchronization
 bgp log-neighbor-changes
 network 172.16.1.0 mask 255.255.255.0   ——②指定BGP要通告的网络
 neighbor 172.16.1.2 remote-as 65101  ——③指定BGP邻居,这里的AS跟②中的AS不同,表明是EBGP。
 no auto-summary  ——默认禁止了汇总,意味着我们在配置network命令(②)的时候所指定的网络应跟路由表中的前缀严格匹配(172.16.1.0/24)

 

R2#show run
!        
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!        
interface Serial1/0
 ip address 10.1.1.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
interface Serial1/1
 ip address 10.2.2.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
interface Serial1/2
 ip address 172.16.1.2 255.255.255.0
 serial restart-delay 0
!        
router eigrp 1
 network 10.0.0.0  ——注意IGP的network命令的含义跟BGP的network命令相差甚远,这里指定哪些接口参与EIGRP进程
 network 192.168.2.0
 auto-summary
!        
router bgp 65101
 no synchronization
 bgp log-neighbor-changes
 network 10.0.0.0
 network 172.16.1.0 mask 255.255.255.0
 neighbor 172.16.1.1 remote-as 65100
 neighbor 192.168.3.3 remote-as 65101
 neighbor 192.168.3.3 update-source Loopback0  ——我们这里用loopback接口地址作为邻居的地址,由于R2没有物理接口直连192.168.3.3,所以我们要加上这一句,同时,还要确保R2的路由表中应该有通往192.168.3.3的路由(本例可以通过EIGRP获得)  
 no auto-summary

 

R3#show run
interface Loopback0
 ip address 192.168.3.3 255.255.255.255
!        
interface Serial1/0
 ip address 10.1.1.2 255.255.255.0
 serial restart-delay 0
!        
interface Serial1/1
 ip address 10.2.2.2 255.255.255.0
 serial restart-delay 0
!        
interface Serial1/5
 ip address 192.168.1.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
router eigrp 1
 network 10.0.0.0
 network 192.168.3.0
 auto-summary
!        
router bgp 65101
 no synchronization
 bgp log-neighbor-changes
 network 10.0.0.0
 network 192.168.1.0
 neighbor 192.168.1.1 remote-as 65102
 neighbor 192.168.2.2 remote-as 65101
 neighbor 192.168.2.2 update-source Loopback0
 no auto-summary

 

R4#show run
!        
interface Serial1/5
 ip address 192.168.1.1 255.255.255.0
 serial restart-delay 0
!        
router bgp 65102
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.0
 neighbor 192.168.1.2 remote-as 65101
 no auto-summary


2. 路由表

R1#show ip route
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial1/2
B    10.0.0.0/8 [20/2169856] via 172.16.1.2, 00:18:58
B    192.168.1.0/24 [20/0] via 172.16.1.2, 00:18:28

R1收到了R3(经过R2)通告的BGP路由,表明配置成功。

R2#show ip route
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial1/2
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Serial1/1
C       10.1.1.0/24 is directly connected, Serial1/0
D       10.0.0.0/8 is a summary, 00:32:54, Null0
B    192.168.1.0/24 [200/0] via 192.168.3.3, 00:19:01
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.2/32 is directly connected, Loopback0
D       192.168.2.0/24 is a summary, 00:32:54, Null0
D    192.168.3.0/24 [90/2297856] via 10.2.2.2, 00:32:36, Serial1/1
                    [90/2297856] via 10.1.1.2, 00:32:36, Serial1/0

 

R3#show ip route
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
B       172.16.1.0 [200/0] via 192.168.2.2, 00:11:00
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Serial1/1
C       10.1.1.0/24 is directly connected, Serial1/0
D       10.0.0.0/8 is a summary, 00:33:09, Null0
C    192.168.1.0/24 is directly connected, Serial1/5
D    192.168.2.0/24 [90/2297856] via 10.2.2.1, 00:33:16, Serial1/1
                    [90/2297856] via 10.1.1.1, 00:33:16, Serial1/0
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.3/32 is directly connected, Loopback0
D       192.168.3.0/24 is a summary, 00:33:09, Null0

 

R4#show ip route
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
B       172.16.1.0 [20/0] via 192.168.1.2, 00:11:30
B    10.0.0.0/8 [20/2169856] via 192.168.1.2, 00:19:54
C    192.168.1.0/24 is directly connected, Serial1/5


3. BGP表

R1#show ip bgp
BGP table version is 4, local router ID is 172.16.1.1

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.0.0         172.16.1.2         2169856             0 65101 i
*  172.16.1.0/24    172.16.1.2               0             0 65101 i
*>                  0.0.0.0                  0         32768 i
*> 192.168.1.0      172.16.1.2                             0 65101 i

 其中带有>的是BGP最佳路由,将会交给路由选择表进程。其中172.16.1.0我们看到两条路由,一条下一跳为172.16.1.2(R2),一条下一跳为0.0.0.0(自己),这里当然选择自己通告的路由作为通往172.16.1.0/24的最佳路由。后面的Path表示BGP经过的路径,例如这里的65101表示使用这条路由通往该目的网络需要经过AS 65101。

R2#show ip bgp
BGP table version is 6, local router ID is 192.168.2.2
   Network          Next Hop            Metric LocPrf Weight Path
* i10.0.0.0         192.168.3.3        2169856    100      0 i
*>                  0.0.0.0            2169856         32768 i
*> 172.16.1.0/24    0.0.0.0                  0         32768 i
*                   172.16.1.1               0             0 65100 i
*>i192.168.1.0      192.168.3.3              0    100      0 i

这里的10.0.0.0和192.168.1.0前面有一个i,表示这条路由是IBGP路由器通告给当前路由器的。而172.16.1.0前面没有i,表示这是从外部路由器获悉的。

 

R3#show ip bgp
BGP table version is 6, local router ID is 192.168.3.3
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.0.0         0.0.0.0            2169856         32768 i
* i                 192.168.2.2        2169856    100      0 i
*>i172.16.1.0/24    192.168.2.2              0    100      0 i
*  192.168.1.0      192.168.1.1              0             0 65102 i
*>                  0.0.0.0                  0         32768 i

 

R4#show ip bgp
BGP table version is 7, local router ID is 192.168.1.1
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.0.0         192.168.1.2        2169856             0 65101 i
*> 172.16.1.0/24    192.168.1.2                            0 65101 i
*> 192.168.1.0      0.0.0.0                  0         32768 i
*                   192.168.1.2              0             0 65101 i

 

 

 

 

  评论这张
 
阅读(625)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018