注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

山林客

简单不一定幸福,但幸福其实可以很简单。

 
 
 

日志

 
 
关于我

2004年毕业于中山大学,毕业后专注于网站开发和网络工程技术。先后取得SCWCD、CCNP认证,对Asp/Java有丰富的开发经验,对网络工程也有较深的研究。真诚欢迎大家多多指教、多多指点、多多指正,共同分享IT道路和人生道路上的喜怒哀乐。

网易考拉推荐

通过修改管理距离优化路由选择  

2008-11-27 18:05:53|  分类: Cisco |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

拓扑图:

通过修改管理距离优化路由选择 - 瑞志.net - Bills Tec. Space

 

一、修改管理距离之前的配置

R1#show run
!        
interface Loopback0
 ip address 10.200.200.31 255.255.255.255
!        
interface FastEthernet0/0
 ip address 10.3.1.1 255.255.255.0
 duplex auto
 speed auto
!        
interface Serial1/0
 ip address 172.31.3.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 serial restart_delay 0
 frame-relay map ip 172.31.3.2 203 broadcast
 frame-relay map ip 172.31.3.3 201 broadcast
!        
router ospf 1
 log-adjacency-changes
 redistribute rip metric 10000 metric-type 1 subnets
 network 172.31.3.0 0.0.0.255 area 0
!        
router rip
 version 2
 redistribute ospf 1 metric 5
 network 10.0.0.0
 no auto-summary

 

R2#show run
!        
interface Loopback0
 ip address 10.200.200.32 255.255.255.255
!        
interface FastEthernet0/0
 ip address 10.3.2.2 255.255.255.0
 duplex auto
 speed auto
!        
interface Serial1/0
 ip address 172.31.3.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 serial restart_delay 0
 frame-relay map ip 172.31.3.1 302 broadcast
 frame-relay map ip 172.31.3.3 301 broadcast
!        
router ospf 1
 log-adjacency-changes
 redistribute rip metric 10000 metric-type 1 subnets
 network 172.31.0.0 0.0.255.255 area 0
!        
router rip
 version 2
 redistribute ospf 1 metric 5
 network 10.0.0.0
 no auto-summary

这里在配置重分发的时候,都把metric设置为较大的值,例如将RIP重分发到OSPF时,其metric修改为10000,这个metric会高于OSPF区域内的其他路由的metric,从而避免了路由反馈。由于这个例子中OSPF区域的三台路由器位于同一个子网,所以这里问题不是很大。我们看下面的RIP区域。

假设我们配置RIP重分发的时候将metric 5修改为metric 1,看会有什么情况发生:

R3#show ip route
Gateway of last resort is not set

     172.31.0.0/24 is subnetted, 1 subnets
R       172.31.3.0 [120/1] via 10.3.1.1, 00:00:26, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C       10.3.1.0/24 is directly connected, FastEthernet0/0
C       10.3.3.0/24 is directly connected, Serial1/0
R       10.3.2.0/24 [120/1] via 10.3.3.4, 00:00:19, Serial1/0
                    [120/1] via 10.3.1.1, 00:00:26, FastEthernet0/0

R       10.200.200.31/32 [120/1] via 10.3.1.1, 00:00:26, FastEthernet0/0
R       10.200.200.34/32 [120/1] via 10.3.3.4, 00:00:19, Serial1/0
R       10.200.200.32/32 [120/1] via 10.3.1.1, 00:00:26, FastEthernet0/0
C       10.200.200.33/32 is directly connected, Loopback0
R       10.254.0.0/24 [120/1] via 10.3.1.1, 00:00:26, FastEthernet0/0

 

R4#show ip route
Gateway of last resort is not set

     172.31.0.0/24 is subnetted, 1 subnets
R       172.31.3.0 [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
R       10.3.1.0/24 [120/1] via 10.3.3.3, 00:00:06, Serial1/0
                    [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0

C       10.3.3.0/24 is directly connected, Serial1/0
C       10.3.2.0/24 is directly connected, FastEthernet0/0
R       10.200.200.31/32 [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0
C       10.200.200.34/32 is directly connected, Loopback0
R       10.200.200.32/32 [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0
R       10.200.200.33/32 [120/1] via 10.3.3.3, 00:00:06, Serial1/0
                         [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0
R       10.254.0.0/24 [120/1] via 10.3.2.2, 00:00:05, FastEthernet0/0

我们看到在R3中的10.3.2.0和R4中的10.3.1.0都有两个出口,分别是经过RIP区域和OSPF区域,形成一个环路。

 

二、修改管理距离之前的路由表

R1#show ip route
Gateway of last resort is not set

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.3.0 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C       10.3.1.0/24 is directly connected, FastEthernet0/0
R       10.3.3.0/24 [120/1] via 10.3.1.3, 00:00:29, FastEthernet0/0
O E1    10.3.2.0/24 [110/10064] via 172.31.3.2, 00:10:55, Serial1/0
C       10.200.200.31/32 is directly connected, Loopback0
R       10.200.200.34/32 [120/2] via 10.3.1.3, 00:00:29, FastEthernet0/0
O E1    10.200.200.32/32 [110/10064] via 172.31.3.2, 00:10:55, Serial1/0
R       10.200.200.33/32 [120/1] via 10.3.1.3, 00:00:29, FastEthernet0/0
O       10.254.0.0/24 [110/65] via 172.31.3.3, 00:10:55, Serial1/0

 可以看到,R1会穿过帧中继网络,然后再经过R2来到达10.3.2.0,而事实上,经过R3-R4来到达,会比经过缓慢的帧中继网络更好。

三、修改管理距离

R1(config)#router ospf 1
R1(config-router)#distance 125 0.0.0.0 255.255.255.255 64
R1(config-router)#exit
R1(config)#access-list 64 permit 10.0.0.0 0.255.255.255

这里将符合ACL64的路由的管理距离修改为125(高于RIP的120)。

 

四、修改管理距离后R1的路由表

R1#show ip route
Gateway of last resort is not set

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.3.0 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C       10.3.1.0/24 is directly connected, FastEthernet0/0
R       10.3.3.0/24 [120/1] via 10.3.1.3, 00:00:29, FastEthernet0/0
R       10.3.2.0/24 [120/2] via 10.3.1.3, 00:00:29, FastEthernet0/0
C       10.200.200.31/32 is directly connected, Loopback0
R       10.200.200.34/32 [120/2] via 10.3.1.3, 00:00:29, FastEthernet0/0
R       10.200.200.32/32 [120/3] via 10.3.1.3, 00:00:29, FastEthernet0/0
R       10.200.200.33/32 [120/1] via 10.3.1.3, 00:00:29, FastEthernet0/0
O       10.254.0.0/24 [125/65] via 172.31.3.3, 00:03:03, Serial1/0

可以看到,由于将管理距离修改得比RIP的大,所以R1会优先选择下面的路径。

 

 

 

  评论这张
 
阅读(1185)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018