注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

山林客

简单不一定幸福,但幸福其实可以很简单。

 
 
 

日志

 
 
关于我

2004年毕业于中山大学,毕业后专注于网站开发和网络工程技术。先后取得SCWCD、CCNP认证,对Asp/Java有丰富的开发经验,对网络工程也有较深的研究。真诚欢迎大家多多指教、多多指点、多多指正,共同分享IT道路和人生道路上的喜怒哀乐。

网易考拉推荐

NBMA中的OSPF模式  

2008-10-30 22:31:56|  分类: Cisco |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

broadcast模式

这种模式就是在非多路访问网络模仿多路访问网络,例如以下帧中继环境的三台路由器,配置这种模式之后,它看起来就像一个总线型的LAN网络。

       

而且它的OSPF特性也跟LAN中的一样:使用组播Hello分组来发现邻居;需要选举DR和BDR,并且要求所有的帧中继链路都位于同一个子网。这种模式要求网络是全互联的,所以耗费的PVC数量比较多,费用也比较昂贵。如果不是全互联的,那么必须手工指定DR/BDR。

配置如下(只配置Router1,其他两台类似):

Router1(config)#interface S0/0/0
Router1(config-if)#ip address 10.1.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast
Router1(config-if)#frame-relay map ip 10.1.1.3 102 broadcast
Router1(config-if)#ip ospf network broadcast
Router1(config-if)#router ospf 1
Router1(config-router)#network 0.0.0.0 255.255.255.255 area 0

由于需要组播分组,所以这里配置映射的时候不要忘了broadcast。另外,这里我们为了简便,将所有网络接口都加入OSPF。

 

non-broadcast模式

这种模式是模拟非广播的LAN网络,它同样要建立邻居,并选举DR/BDR。不过,它只要求所有的路由器都必须要跟DR/BDR相连,至于其他路由器,连不连没有关系。因为在在一个稳定的LAN环境OSPF网络中,所有的DROTHER也只会和DR/BDR建立邻接关系,所以这种模拟也是可行的。 

由于是非广播网络环境,但又要广播网络那些特性,所以处理上就有所不同。由于是非广播,所以不能通过组播Hello分组来发现邻居,所以,邻居必须是手工配置的。另外,在广播型的LAN环境中,LSA是通过组播地址224.0.0.6发送给DR/BDR的,但这里由于不能广播,所以发送LSA的时候实际上都是拷贝两份发给DR/BDR,而DR/BDR转发这些LSA的时候也要拷贝多份然后单播给其他DROTHER。

Router1(config)#interface S0/0/0
Router1(config-if)#ip address 10.1.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#frame-relay map ip 10.1.1.2 102
Router1(config-if)#frame-relay map ip 10.1.1.3 102
Router1(config-if)#frame-relay map ip 10.1.1.4 104
Router1(config-if)#router ospf 1
Router1(config-router)#network 0.0.0.0 255.255.255.255 area 0
Router1(config-router)#neighbor 10.1.1.2
Router1(config-router)#neighbor 10.1.1.3
Router1(config-router)#neighbor 10.1.1.4

这里我们并没有使用“ip ospf network non-broadcast”来显式指明OSPF网络模式,因为帧中继默认就是这种模式。我们使用neighbor命令来指定路由器邻居。对方可以不配置neighbor命令,只要一方配置了就可以。

 

point-to-point模式

 点到点模式无需选举DR/BDR,因为只有两台路由器,而且每个接口/子接口都属于不同的子网,这种模式采用组播来发送OSPF分组(组播地址224.0.0.5),因此它无需手工配置邻居,换句话说,它可以自动发现邻居。另外它无需选举DR/BDR,在广播多路访问网络,我们之所以需要DR/BDR,其中一个原因就是为了节省流量,但这里只有两台路由器,所以起不到任何作用。

Router1(config)#interface Serial0
Router1(config-if)#ip address 10.1.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast
Router1(config-if)#ip ospf network point-to-point
Router1(config-if)#router ospf 1
Router1(config-router)#network 10.1.1.0 0.0.0.255 area 0

 

point-to-multipoint广播模式

这种模式相当于多条point-to-point链路,所以它也具有point-to-point的特性:自动发现邻居,不用选举DR/BDR。它跟point-to-point最大的不同是,它的帧中继链路需要位于同一个子网。另外,在发送LSU的时候,它必须为每个链路提供一个拷贝。

Router1(config)#interface Serial2/0
Router1(config-if)#ip address 10.1.1.1 255.255.255.0
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast
Router1(config-if)#frame-relay map ip 10.1.1.3 103 broadcast
Router1(config-if)#no frame-relay inverse-arp
Router1(config-if)#ip ospf network point-to-multipoint
Router1(config)#router ospf 100
Router1(config-router)#log-adjacency-changes
Router1(config-router)#network 0.0.0.0 255.255.255.255 area 0

 

point-to-multipoint非广播模式

根point-to-multipoint非广播模式的最大区别就是要手工指定邻居。其他的特性跟point-to-multipoint广播模式相同:不选举DR/BDR。

Router1(config)#interface Serial2/0
Router1(config-if)#ip address 10.1.1.1 255.255.255.0
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#frame-relay map ip 10.1.1.2 102
Router1(config-if)#frame-relay map ip 10.1.1.3 103
Router1(config-if)#no frame-relay inverse-arp
Router1(config-if)#ip ospf network point-to-multipoint non-broadcast
Router1(config)#router ospf 100
Router1(config-router)#log-adjacency-changes
Router1(config-router)#network 0.0.0.0 255.255.255.255 area 0
Router1(config-router)#neighbor 10.1.1.2
Router1(config-router)#neighbor 10.1.1.3

  评论这张
 
阅读(502)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018