注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

山林客

简单不一定幸福,但幸福其实可以很简单。

 
 
 

日志

 
 
关于我

2004年毕业于中山大学,毕业后专注于网站开发和网络工程技术。先后取得SCWCD、CCNP认证,对Asp/Java有丰富的开发经验,对网络工程也有较深的研究。真诚欢迎大家多多指教、多多指点、多多指正,共同分享IT道路和人生道路上的喜怒哀乐。

使用DynamipsGUI模拟帧中继(OSPF 5种NBMA模式实验)  

2008-10-31 08:04:38|  分类: Cisco |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

本实验使用DynamipsGUI软件,该软件的安装这里不做详述,自己去Google搜索。

首先看拓扑:

上图中用圆圈圈起来的是帧中继交换机的端口,使用DynamipsGUI软件会提供一个模拟的帧中继交换机,我们并不需要自己配置,只需要设置DLCI及将有关端口连接起来即可。

 

1. 启动DynamipsGUI,路由器个数为4个,设备类型选择“7200”,选中“模拟帧中继”,然后会弹出一个“帧中继交换机自定义设置”对话框。

 

根据我们预先定义的PVC填上DLCI号

 

2. 选择“7200”系列路由器IOS镜像,该镜像可以在网络上搜索下载

 

3.  点击“计算idle”按钮,弹出一个DOS窗口。

 

稍候片刻,它会进入IOS的界面,并提示“Would you like to enter the initial configuration dialog? [yes/no]:”,我们选择“no”

等它的信息输出完毕,然后按组合键“Ctrl + ]”,接着松开,再按i键,它就会计算Idle的值,选择count的值最大的那个,把它填写到“idle-pc值”输入框。这里为0x612741dc

 

点击“确定”,选择“输出目录”,然后“下一步”。

4. 接下来是配置每台设备的模块,这里我们使用了两个模块,一个是快速以太网口的,另一个是串口的,配置完点击确定配置,并记下Console口(就是我们待会Telnet需要用到的端口),然后配置下一台,这里我们一共要配4台路由器。

 

配置完成之后点击下一步,又会弹出一个DOS窗口,等它运行完我们可以把它关闭。

 

5. 接下来需要我们将这些设备的端口连接起来。根据我们的拓扑所示的端口号,我们把它们逐个连接起来。

 

最后点击“保存拓扑配置文件”来保存配置,并点击“生成.BAT文件”来生成我们的运行模拟路由器的BAT文件。然后退出。

 

6. 找到你刚才设置的输出目录,在下面应该会有一个“pc1”目录,目录下会有4个.BAT文件,分别代表4台路由器,依次双击启动。注意,这里只是启动硬件,并不是进入IOS命令窗口,我们还需要Telnet到路由器上才能进行我们的操作。
你可以直接使用DOS窗口,输入命令:telnet 127.0.0.1 2001  这里的2001是Router1的端口
但我建议使用SecureCRT软件,因为它可以在一个窗口中打开多个Telnet窗口

 

下面我们开始用这个环境来做OSPF NBMA模式的实验。

1. 广播模式(broadcast)

各台路由器的关键配置信息如下:

R1:

interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex half
!        
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 serial restart-delay 0
 frame-relay map ip 192.168.1.2 102 broadcast

!
router ospf 100
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0

 

R2:

interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast

!        
router ospf 100
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0

 

R3:

interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 301 broadcast

!        
router ospf 100
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0

 

R4:

interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.0
 duplex half

!        
router ospf 100
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0

 

在R1上执行debug ip ospf events,可以看到邻接关系的建立过程

R1#
*Nov  1 18:32:16.779: OSPF: Send DBD to 192.168.1.3 on Serial1/0 seq 0x1D48 opt 0x52 flag 0x7 len 32
*Nov  1 18:32:16.779: OSPF: Retransmitting DBD to 192.168.1.3 on Serial1/0 [5]
R1#
*Nov  1 18:32:18.607: OSPF: Rcv hello from 192.168.1.3 area 0 from Serial1/0 192.168.1.3
*Nov  1 18:32:18.607: OSPF: Neighbor change Event on interface Serial1/0
*Nov  1 18:32:18.607: OSPF: DR/BDR election on Serial1/0
*Nov  1 18:32:18.607: OSPF: Elect BDR 192.168.1.1
*Nov  1 18:32:18.611: OSPF: Elect DR 192.168.1.3
*Nov  1 18:32:18.611: OSPF: Elect BDR 192.168.1.1
*Nov  1 18:32:18.611: OSPF: Elect DR 192.168.1.3
*Nov  1 18:32:18.611:        DR: 192.168.1.3 (Id)   BDR: 192.168.1.1 (Id)
*Nov  1 18:32:18.611: OSPF: Remember old DR 192.168.1.2 (id)
*Nov  1 18:32:18.615: OSPF: Neighbor change Event on interface Serial1/0
*Nov  1 18:32:18.615: OSPF: DR/BDR election on Serial1/0
*Nov  1 18:32:18.615: OSPF: Elect BDR 192.168.1.1
*Nov  1 18:32:18.615: OSPF: Elect DR 192.168.1.3
*Nov  1 18:32:18.615:        DR: 192.168.1.3 (Id)   BDR: 192.168.1.1 (Id)
*Nov  1 18:32:18.619: OSPF: End of hello processing
*Nov  1 18:32:18.623: OSPF: Rcv DBD from 192.168.1.3 on Serial1/0 seq 0x1
R1#120 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Nov  1 18:32:18.623: OSPF: NBR Negotiation Done. We are the SLAVE

 

在R4上查看链路状态数据库

R4#show ip ospf database

            OSPF Router with ID (172.16.1.2) (Process ID 100)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.1.2      172.16.1.2      259         0x80000002 0x0041F2 1
192.168.1.1     192.168.1.1     365         0x80000007 0x005633 3
192.168.1.2     192.168.1.2     300         0x80000003 0x006BD4 1
192.168.1.3     192.168.1.3     268         0x80000003 0x0073C8 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.1.1      192.168.1.1     365         0x80000002 0x00DC07
192.168.1.2     192.168.1.2     530         0x80000001 0x00A2E6
192.168.1.3     192.168.1.3     525         0x80000001 0x009CE9

 

从R4 ping R3,成功

R4#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

2. 点到多点广播模式(point-to-multipoint)

只需要将R1、R2、R3的模式修改一下即可,例如:

R3(config-if)#ip ospf netw point-to-multipoint

 

3. 点到多点非广播模式(point-to-multipoint broadcast)

需要修改三个地方:模式加non-broadcast、帧中继映射去掉broadcast、设置邻居

R1(config-if)#ip ospf network point-to-multipoint non-broadcast
R1(config-if)#frame-relay map ip 192.168.1.3 102
R1(config-if)#frame-relay map ip 192.168.1.3 103

R1(config-router)#neighbor 192.168.1.2
R1(config-router)#neighbor 192.168.1.3

R2、R3不需要配置neighbor,只要一方配置了就可以

R2(config-if)#ip ospf network point-to-multipoint non-broadcast
R2(config-if)#frame-relay map ip 192.168.1.1 201

这种模式下使用单播来发送OSPF分组

R1#
*Nov  1 21:21:15.051: OSPF: Send hello to 192.168.1.3 area 0 on Serial1/0 from 192.168.1.1
*Nov  1 21:21:15.051: OSPF: Send hello to 192.168.1.2 area 0 on Serial1/0 from 192.168.1.1
*Nov  1 21:21:15.111: OSPF: Rcv hello from 192.168.1.3 area 0 from Serial1/0 192.168.1.3
*Nov  1 21:21:15.111: OSPF: End of hello processing

4. 非广播模式(non-broadcast)

只要将R1、R2、R3的模式修改一下即可

R1(config-if)#ip ospf network non-broadcast

这种模式使用单播发送hello

R1#
*Nov  1 21:43:02.627: OSPF: Send hello to 192.168.1.2 area 0 on Serial1/0 from 192.168.1.1
*Nov  1 21:43:02.627: OSPF: Send hello to 192.168.1.3 area 0 on Serial1/0 from 192.168.1.1

 

5. 点到点模式(point-to-point)

这个模式我们需要用到子接口,所以需要清除R1上S1/0的配置。我们将R1到R2的子网设为192.168.1.0/24,R1到R3的子网设为192.168.2.0/24

R1(config-if)#no ip address
R1(config-if)#no frame-relay map ip 192.168.1.2 102
R1(config-if)#no frame-relay map ip 192.168.1.3 103
R1(config-if)#no ip ospf network point-to-multipoint non-broadcast
R1(config-if)#interface s1/0.1 point-to-point
R1(config-subif)#frame-relay interface-dlci 102
R1(config-fr-dlci)#exit
R1(config-subif)#ip ospf network point-to-point

R1(config)#router ospf 100
R1(config-router)#network 192.168.2.0 0.0.0.255 area 0
注意上面要使用frame-relay interface-dlci命令。

另外,也不需要手动指定邻居,所以我们可以清除两个neighbor命令

R1(config-router)#no neighbor 192.168.1.2
R1(config-router)#no neighbor 192.168.1.3

R2、R3的配置

R2:

interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-point
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast

!        
router ospf 100
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0

注意,这里的frame-relay map后面一定要有broadcast,否则会失败,因为需要用到组播(每个子接口都会发送组播)。

R3:

!        
interface Serial1/0
 ip address 192.168.2.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-point
 serial restart-delay 0
 frame-relay map ip 192.168.2.1 301 broadcast

!        
router ospf 100
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0

验证:

R1#
*Nov  1 22:22:50.990: OSPF: Rcv hello from 172.16.1.2 area 0 from FastEthernet0/0 172.16.1.2
*Nov  1 22:22:50.994: OSPF: End of hello processing
*Nov  1 22:22:51.178: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.2 from 192.168.2.1
R1#
*Nov  1 22:22:52.258: OSPF: Rcv hello from 192.168.1.3 area 0 from Serial1/0.2 192.168.2.2
*Nov  1 22:22:52.258: OSPF: End of hello processing
*Nov  1 22:22:53.058: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.1 from 192.168.1.1
R1#
*Nov  1 22:22:54.778: OSPF: Rcv hello from 192.168.1.2 area 0 from Serial1/0.1 192.168.1.2
*Nov  1 22:22:54.778: OSPF: End of hello processing

  评论这张
 
阅读(2011)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018